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MOHID Graphical User Interfaces 

1 MOHID Graphical User Interface Overview 

1.1 Introduction 

The graphical user interfaces of the MOHID Water Modeling System are a set of 

programs to pre and post process the input and output data needed by the different 

numerical programs. This chapter describes how the user interfaces integrated in the 

MOHID Water Modeling System work and how they interact with the numerical code. 

After installing the MOHID Water Modeling System the user can access MOHID 

graphical user interfaces by selecting Start -> All Programs -> Mohid, like shown in 

Figure 1-1. 

 

Figure 1-1: Access to the MOHID Graphical User Interface after program installation 

The core graphical user interfaces are: 

• MOHID GUI – a graphical user interface to handle file structure organization of 

all files which are needed to set up a MOHID numerical simulation; 

• MOHID GIS – a geographical information system which handles spatial and 

temporal variable data required or produced by MOHID numerical programs; 

• MOHID Post – a graphical user interface which displays data stored in HDF files 

as animation on the screen; 

• MOHID Time Series Editor – a graphical user interface which allows the user to 

visualize in a quick way time series data required or produced by MOHID 

numerical programs. 

1-1 



MOHID Graphical User Interfaces 

Data exchange between MOHID Graphical User Interfaces and MOHID numerical 

programs is done by files. There are two types of files which are used: (i) ASCII text files 

which follow a proper formatting and HDF files. More information can be found in the 

document “MOHID Data Files – Overview”. 

In the following chapters it is described how this set of programs work. 
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2 MOHID GUI 

2.1 Introduction 

MOHID GUI is a graphical user interface to handle the organization of the input and 

output files required by the MOHID numerical programs. At the present state, MOHID 

GUI can act as user interface for the following numerical programs: 

• MOHID Water – numerical program which permits to simulate surface water 

bodies; 

• MOHID Land  – numerical program which permits to simulate basins; 

• MOHID River Network – numerical program which permits to simulate River 

Networks; 

• MOHID Soil – numerical program which simulates small scale soil dynamics. 

The main window of MOHID GUI is divided into three areas: (i) a tree view docked to 

the left border of the main window, (ii) a list view located on the upper right side of the 

main window and (iii) a text box located on the lower right side of the main window. 

Figure 2-1 shows an example of MOHID GUI’s main window. 
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Figure 2-1: MOHID GUI’s main window 

MOHID GUI organizes simulations by dividing them into four major units: (i) projects, 

(ii) simulations, (iii) runs and (iv) modules. MOHID GUI can work in two different 

modes: (i) preprocessing mode and (ii) post processing mode. 

2.2 Internal Organization 

A project is the topmost unit and groups one or more simulations. Only one project can 

be open by MOHID GUI at a time. Any project has an associated project directory which 

must be specified by the user whenever a new project is created. In the tree view window 

a project is always represented by the topmost node, like shown by node “Reservoirs” in 

Figure 2-1. 

A simulation is an intermediate unit and groups together a set of runs. Simulations 

contain information which are common to all runs of a given simulation. This 

information is: 

• The type of runs to be executed (MOHID Water, MOHID Land or MOHID River 

Network); 
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• The geographical base data (bathymetry for MOHID Water and topography for 

MOHID Land); 

• Tidal information for the open boundary (MOHID Water only). 

In the case of MOHID Water, simulations can be inserted into simulations. This allows 

the user to create nested simulations, which will be understood by MOHID GUI as a user 

option to run a model with a sub-model. An infinite number of nested simulations can be 

inserted, only limited by the user’s available computational resources. Figure 2-1 shows 

four simulations: Paracana, Esquematic, MonteNovo and Montargil. The text box 

window can be used to write down comments for the selected simulation. 

Each run corresponds to one execution of the selected numerical program and is 

characterized by a time span for which the run will be executed. A run is also constituted 

by the modules which are to be used during the run. Runs can be inserted into runs in two 

ways: (i) as temporal sequence or (ii) parallel to each other. Figure 2-1 shows seven runs 

from simulation Montargil, which are all parallel to each other, except run “Continous” 

which is a temporal sequence of run “LowerWaterTable”. This means that run 

“Continuous” initial conditions are given by the last computed instant of run 

“LowerWaterTable”. 

The text box window can be used to write down comments for the selected run. 

Modules 

Modules are associated to runs and are listed in the list view in the upper right side of 

MOHID GUI’s main window. By selecting a given run in the tree view, the 

corresponding modules will be listed in the list view. If MOHID GUI is in preprocessing 

mode, by double-clicking an icon in the list view, the input data file of the selected 

module will open. If MOHID GUI is in post-processing mode, the HDF and time series 

results files for each module, are listed in the list view. By double-clicking an icon in the 

list view in post processing mode, MOHID GUI will open either MOHID Post (in the 

case the selected icon corresponds to an HDF File produced by a given module) or 

MOHID Time Series Editor (in the case the selected icon corresponds to a time series file 

produced by the correspondent module). 
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2.3 Step by Step 

This chapter describes step by step how to use MOHID GUI to create a new project, 

inserting simulations and runs and how to access module data file, executing the 

numerical programs and how to launch the post processing programs MOHID Post and 

MOHID Time Series Editor. 

2.3.1 Creating a Project 

To create a new project, MOHID GUI must be started by selecting Start -> Programs -> 

Mohid -> MOHID GUI. An empty window of MOHID GUI will appear (Figure 2-2).  

 

Figure 2-2: An empty window of MOHID GUI 

A new project can be created by selecting Project -> New… from MOHID GUI’s main 

menu. A small dialog box, like shown in Figure 2-3, will appear and asks the user to 

supply information for the project name, the filename of the project (extension should be 

*.moh) and the root location for the project. 

 

Figure 2-3: Dialog box to specify Project settings 
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After closing the dialog box, the root node which corresponds to the project node will be 

inserted into the tree view of MOHID GUI’s main window. By closing the dialog box 

MOHID GUI will also create three subdirectories in the project directory: (i) a directory 

called “Figures” which can be used to place figures created within the project, (ii) a 

directory called “GeneralData” which can be used to store generic data (e.g bathymetric 

information, atmospheric conditions input files, etc.) and (iii) a directory called “Temp” 

to place temporary files. 

2.3.2 Insert a Simulation 

Before inserting a new simulation into a project, the user should have already prepared 

the necessary data for the simulation (e.g. bathymetry file for MOHID Water or 

topography file for MOHID Land) using MOHID GIS or other sources. It’s 

recommended to store these files in the directory “GeneralData” mentioned above. 

To insert a new simulation the root tree node in the tree view must be select (or the 

simulations where a sub model is to be inserted). After selecting the desired node, a new 

simulation can be inserted by selecting Edit -> Insert Simulation from MOHID GUI’s 

main menu. A dialog box, like shown in Figure 2-4, will appear. Here the user can 

specify the properties of the simulation: (i) the name of the simulation, (ii) the type of 

simulation, the path to the grid data file (bathymetric file for MOHID Water or 

topographic file for MOHID Land) and optionally the path to the file which contains the 

tidal components (MOHID Water only). 

 

 Figure 2-4: Dialog box to specify Simulation settings 
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After closing the dialog box shown in Figure 2-4, a node for the simulation will be added 

to the tree view. By closing the dialog box MOHID GUI will also create a subdirectory in 

the project directory, with a name equal to the name of the simulation. Inside of this 

directory three further directories will be created: (i) a directory called “data” where the 

input data files for the modules will be stored, (ii) a directory called “exe” which will be 

used by numerical model as working directory and (iii) a directory called “res” where the 

results files produced by the numerical models will be stored. 

After inserting the simulation, the tree view should look like shown in Figure 2-5. 

 

Figure 2-5: Tree view after inserting one simulation 

It’s possible to access and change the properties of the simulation by selecting the 

simulation in the tree view and then select Edit -> Properties from MOHID GUI’s main 

menu. 

2.3.3 Insert a Run 

To insert a new run, the tree node where the run is to inserted must be selected first. This 

node can either be a simulation node or a run node, depending of the option if the user 

wants to insert a first run into a simulation or temporal sequence of a previous existing 

run. After selecting the desired node, a new run can be inserted by selecting Edit -> Insert 

Run from MOHID GUI’s main menu. A dialog box, like shown in Figure 2-6, will 

appear. Here the user can specify the properties of the run: (i) name of the run, (ii) initial 

date, (iii) final date, (iv) time step and (v) GMT zone. By selecting the tab “Associated 

Modules”, the user can select the modules to be activated for the selected run.  

In case of inserting a run a temporal sequence MOHID GUI will set the start date of the 

newly inserted run automatically to the end date of the previous run and the end date of 

the new run equal to the its start date plus one day. 
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Figure 2-6: Dialog box to specify Run properties 

It’s possible to access and change the properties of the run by selecting the run in the tree 

view and then select Edit -> Properties from MOHID GUI’s main menu. 

Each run will receive automatically an Identification Number(ID). All files which belong 

to a given run will contain this ID at the end, before the extension of the file. For 

example, the input file for the hydrodynamic module of the run with ID 5 will be called 

“Hydrodynamic_5.dat”. 

After selecting a given run, its associated modules will be listed in the list view.  

After inserting a set of runs, the tree view window should look like the one shown in 

Figure 2-7. 

 

Figure 2-7: Tree view with a set of runs 
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2.3.4 Accessing Module Data Files 

Like mentioned previously, module data file can be accessed by double-clicking on the 

icon in the list view. Every time the user selected a different node in the tree view, the list 

view is actualized, showing the modules associated with the selected run. The list view 

shows for each module also information about: (i) the relative path to the data file, (ii) the 

time the file was last accessed and (iii) the size of the file. 

After double-clicking, the module data files can open in two ways: (i) in a user defined 

text editor (which, by default, is “Notepad”) or (ii) using an internal graphical user 

interface. The first ways guarantees the user really “sees” what is inside the data file. The 

second way is more user friendly, but provides only a limited access to modules 

computing options and just for a few modules. Therefore it’s recommended to edit your 

files using a text editor. Figure 2-8 shows a screenshot of users desktop after accessing 

the geometry data file. 

All MOHID data files are organized using a proper formatting, which is described in 

“MOHID Data Files – Overview”. A complete list of all keywords and blocks which can 

be specified in a data file can be found at 

http://www.mohid.com/MembersArea/KeyWords.htm. At MOHID web site download 

area a set of sample data files is also available. 

To change the way module data files are opened select Tools -> Options -> Data Files / 

Tools from MOHID GUI’s main menu. 
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Figure 2-8: Screen shot of user desktop after opening a module data file 

2.3.5 Copying data files among runs 

MOHID GUI allows to copy module data files between runs, in a very similar way it is 

done by “Windows Explorer”. To copy module data files it’s necessary to first select the 

source run in the tree and then the desired modules data files in the list view. Using the 

Ctrl-key permits the user to select multiple files. After selecting the files, the user has to 

choose Edit -> Copy from MOHID GUI’s main menu. The next step is to select the 

desired destination run and select Edit -> Paste from MOHID GUI’s main menu. Note 

that keyboard short cut keys for Copy (Control + C) and Paste (Control + V) operations 

are also available. If the user copies the module data file of the module “Model”, the 

definition of the associated modules to the run is also copied. Please keep in mind this 

feature and re-edit Run properties to redefine the modules to be used. 

2.3.6 Running the Numerical Programs 

After setting up all module data files, it’s possible to launch the numerical programs from 

MOHID GUI, by selecting Tools -> Launch Mohid from MOHID GUI’s main menu. A 

dialog box like the one shown in Figure 2-9 appears. On the left side of the dialog box 

appears a copy of the tree view which is also found on the left side of MOHID GUI’s 

main window. By checking the check boxes next to the tree nodes, the user selects the 
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runs that will be executed. Several runs can be chosen at the same time, they will be 

executed sequentially. Runs from different simulations can be chosen. On the right hand 

side of the dialog box some options appear that control the way the run is executed. If the 

user wants to execute numerical programs the option “Run Mohid” must be checked. In 

this case the option “Create Nomfichs” should also be checked. Other options are: 

• DTLog – writes model time step to a file (just relevant if the model runs with a 

variable time step); 

• OutWatch – performance internal CPU monitoring while the numerical program 

runs and writes a log file at the end of the run; 

• Output – can be either to the DOS screen or be redirected to a file; 

• MPI – this option can be used if the user wants to run models and sub models 

distributed over a network; 

• Launch after OK – this option launches the batch file which will start all chosen 

runs immediately after closing the dialog box; 

• Batch File – The name of the Batch File; 

• Priority – The priority in the system “Task Manager”. 
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Figure 2-9: Dialog box to launch the numerical programs 

If the option “Launch after OK” was checked, immediately after closing the dialog box, a 

DOS window like shown in Figure 2-10 should appear. Several messages will be 

displayed during the constructing phase of the numerical model, which inform the user 

about most important compute options.  
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Figure 2-10: MOHID numerical program during constructing phase 

When the numerical program passed trough all constructing phase, a message saying 

“Running MOHID, please wait…” will appear. Approximately 60 seconds after this 

message, and from this point forward 60 in 60 seconds, a message will appear in the DOS 

window which will inform the user about (see Figure 2-11):  

• Time Instant – the current time instant which the numerical model is simulating; 

• Elapsed CPU Time – the processor time the numerical needed for far; 

• Remaining – the remaining processor time until the end of the run; 

• Coefficient CPU / Model – the coefficient between the processor time needed so 

far and the time span simulated so far; 

• Seconds per iteration – the time spend to complete one working cycle; 

• System time – the actual system time; 

• End of the run – the foreseen system time at the end of the run.  

 

Figure 2-11: MOHID numerical program during the working cycle 

During the numerical programs launching process, a set of input and output operations 

will take place: 

• If the option “Create Nomfichs” is activated, for each selected run, a data file in 

the subdirectory “data” is created. This file contains links which indicate the 

numerical models where to find module data files and where to place output data 
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files. Each run has its own “Nomfich” placed in the “data” subdirectory (name of 

each “Nomfich” file will be “Nomfich_ID.dat”, where ID represents the run ID); 

• Immediately before starting MOHID numerical program, the batch file will copy 

the “Nomfich_ID.dat” file of the run to be executed into the “exe” subdirectory, 

renaming it to “nomfich.dat”. In this directory MOHID numerical models expect 

always a “Nomfich.dat” file; 

• MOHID GUI creates, for each run to be executed, a subdirectory in the “res” 

subdirectory. These subdirectories will be called “RunID”, where ID is replaced 

by the ID of the run. Time series produced by MOHID numerical models will be 

placed in these subdirectories; 

• During run execution, in the “exe” subdirectory two files will be created: (i) a file 

called “ErrorAndMessages.log” which contain warning messages produced by 

MOHID numerical models and (ii) a file called “UsedKeyWords.dat” which 

contains a list of all keywords read by the numerical model during the constructor 

phase. 

At the end of the execution of a numerical program, the DOS window should look like 

the one shown in Figure 2-12. Some information related to total processor time is 

displayed.  

 

Figure 2-12: MOHID numerical program after successful execution 
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2.3.7 Removing Simulations and Runs 

To remove simulations or runs, the user has to select the simulation (or run) to remove in 

the tree view and select Edit -> Delete from MOHID GUI’s main menu. The selected 

simulation (or run) and all “child” simulations (or runs) will be removed. A dialog box 

(Figure 2-13) will appears where the user has to confirm to remove the selected run(s). 

 

Figure 2-13: Dialog box to confirm to delete a set of runs 

2.3.8 Switching to Post processing Mode 

After successful run execution, it’s possible to switch MOHID GUI from pre processing 

mode to post processing mode, by selecting Mode -> Post Processing from MOHID 

GUI’s main menu. In Post Processing mode the list view of MOHID GUI’s main window 

will display result files produced by MOHID numerical models. At the top of the list 

view, HDF files are listed followed by time series produced by the model. By double-

clicking on any HDF file, MOHID Post will start and open the selected file. Double-

clicking on a second HDF file, will add the file to MOHID Post. A double-click on any 

time series will start MOHID Time Series Editor. 
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Figure 2-14: MOHID GUI in Post Processor Mode 
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3 MOHID GIS 

3.1 Introduction 

MOHID GIS is a geographical information system which handles spatial and temporal 

variable data required or produces by the MOHID numerical programs. It allows to load 

and to visualize data stored in different formats: 

• MOHID Internal Data Files – files which contain geographical information like 

points, lines, polygons, grids, etc formatted in a proper way. All these files are 

ASCII files; 

• ESRI Shape Files – files which are the used by the ESRI ArcView software; 

• MOHID HDF5 Files – files written in standard HDF5, but with some special data 

sets which contain spatial and temporal information; 

The main window of MOHID GIS has one main menu and a client area where the child 

windows are located. A child window is divided into two areas: (i) a list view docked to 

the left border of the window and (ii) the display area, which occupies the rest of the 

window, where the information is displayed.  
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Figure 3-1: MOHID GUI’s main window 

MOHID GIS organizes information by dividing it into three units: (i) projects, (ii) views 

and (iii) data items. 

3.2 Internal Organization 

A project is the topmost unit and groups together one or more views. Only one project 

can be open by MOHID GIS at a time. Any project has an associated project file where 

all project information is stored.  

A view corresponds to one child window. Data Items are added to a child window and 

displayed by it. An infinite number of views can be created in a project, only limit by the 

user’s computational resources. There are different types of views:  

• XY View – display information as “seen from the top” or, in other words, as a XY 

plane; 

• 3D View – displays information in three-dimensional space. 
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A data item is set of single data entities. Data items can be off different types: 

• Points – a set of XYZ points with optional name, stored in MOHID internal data 

format; 

• Polygons – a set of polygons, without holes, stored in MOHID internal data 

format; 

• Lines – a set of lines, stored in MOHID internal data format; 

• Grids – a file which defines a grid, as used by MOHID numerical programs; 

• Grid Data – a file which defines a grid and the respective center cell values, as 

used by MOHID numerical programs; 

• Background Image – an ASCII file which indicates the path to an image to be 

displayed and its geo-reference settings; 

• Drainage Network - a file which defines a drainage network, as used by MOHID 

numerical programs; 

• River Cross Sections - a file which defines river cross sections, as used by 

MOHID numerical programs; 

• Time Series – a file which contains a time series, as used by MOHID numerical 

programs. 

• HDF5 File – a file written in HDF5, but with some special data sets which 

contain spatial and temporal information; 

• ESRI Shapefile – any valid ESRI Shapefile, containing points, multi points, lines, 

multi lines, polygons or multi polygons; 

The first nine data items are files written in the so called MOHID internal data format, 

while the HDF 5 files and the ESRI Shapefiles are written in other formats. 
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3.3 Step by Step 

The chapter describes step by step how to use MOHID GIS to create a new project, create 

views and add data items, change display settings, add legends, save images, animate 

model results and how to use tools to preprocess data for MOHID numerical models. 

3.3.1 Creating a Project 

To create a new project, MOHID GIS must be started by selecting Start -> Programs -> 

Mohid -> MOHID GIS. An empty window of MOHID GIS will appear (Figure 3-2).  

 

Figure 3-2: An empty window of MOHID GIS 

A new project can be created by selecting File -> New -> Project… from MOHID GIS’s 

main menu. A dialog box will appear where one has to specify location and name of the 

project file (extension should be *.mgp). After closing the dialog box, MOHID GIS adds 

automatically a new XY View to the project and the main menu activates. 

3.3.2 Adding a View 

To add further views to the project, one has to select File -> New -> XY View… or File -

> New -> 3D View… from MOHID GIS’s main menu. 

3.3.3 Adding Data Items 

To add a new data item to a view, one has to activate first the view where the new data 

item is to be added to. Afterwards, by selecting Data Items -> Add… from MOHID 

GIS’s main menu a dialog box appears, that enables to specify the type and location of 
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the data item to be added, as shown in Figure 3-3. Multiple data items of the same kind 

can be added at the same time. 

 

Figure 3-3: Adding an existing Data Item 

After adding an existing data item, an icon of the newly added data item will be added at 

the end of the list view and MOHID GIS’s main might look like seen in Figure 3-4. 
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Figure 3-4: MOHID GIS’s main window with some Data Items 

3.3.4 Data Items Appearance 

Data Items appear, in XY Views, as layers. The topmost data item in the list view is 

represented as topmost layer, while the last data item is the lowest layer. It’s possible to 

change the order of the data items by dragging them up and down with the mouse. It’s 

also possible to turn individual data items on or off by toggling the check box next to the 

icons of the data items in the list view. 

The way data items are displayed depends on several settings. Settings depend on the 

type of data items. Settings can be accessed by selecting a data item in the list view and 

then choosing Data Items -> Properties from MOHID GIS’s main menu (keyboard 

shortcut is F4 and mouse right-click pop up a shortcut menu). Figure 3-5 shows the 

properties of a XYZ Points data item. Common to all data items is information stored in 

groups “General” and “Color”. The first group shows the path to the data item’s file and 

information on it’s position and extension in the XY plane  of it. The second group 

allows the user to choose how to “color” data items and if one wants to display a color 

scale in the display area. 

For some data items its necessary to specify a size (e.g. size of points, width of lines). If 

this size is not supplied in pixels, then it’s necessary to taken into account that values 

specified depend on which type of coordinates one is using. If one is using metric 
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coordinates, size values will be in meters, if one uses geographic coordinates, size values 

will be in decimal degrees.  

 

Figure 3-5: Properties of a XYZ data item 

Color properties of data items can be accessed through the “Settings…” button in the 

“Color” group. Colorization is based on one value, the color base value. Available color 

base values depend on the type of data item (e.g. Z for points, ID for polygons). If there is 

more then one available color base value it can be chosen from the drop down box 

labeled “Based On”.  

By clicking the “Settings…” button in the “Color Group”, a dialog window like shown in 

Figure 3-6 will appear. This dialog box enables the user to colorize data items in different 

ways:  

• constant – all entities of the data items are colored with one single color, since the 

value of the color base value is within the range specified in the “Limits Group”. 

If the value is below limit the color specified in the below limit area is applied. If 

the value exceeds the maximum value, the above limit color is applied; 

• gradual – all entities of the data items are colored based on a gradual color scale. 

Colors are obtained by linear or logarithmic interpolation based on limits in the 
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“Limits Group” and the color base value. For entities with values outside limits 

the same rules as for constant colorization apply; 

• classified – all entities of the data items are colorized based on a user defined 

classified color ranges. For entities with values outside limits the same rules as for 

constant colorization apply. 

 

Figure 3-6: Color Setting Dialog 

3.3.5 Create New Data Items  

MOHID GIS permits to create some data items from scratch. By selecting Data Items -> 

New… from MOHID GIS’s main menu, a dialog window like the one shown Figure 3-7 

appears. Here it’s possible to choose the type of data item to be created and where the 

respective file will be located. 

 

Figure 3-7: Adding a new Data Item 
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3.3.6 Removing Data Items 

By selecting one or more data items for the list view and selecting Data Items -> Remove 

from MOHID GIS’s main menu data items will be removed from the view. 

3.3.7 Adding Single Data Entities 

It’s possible to add single data entities to existing XYZ, lines and polygon data items. 

First one has to select in the list view the data item where to add the entities to. The next 

step is to select Tools -> Add -> Add Points / Lines / Polygons from MOHID GIS’s main 

menu.  

Points are added with the left mouse button on the display area. To stop adding points, 

the right mouse button must be pressed. 

Lines vertex are added with the left mouse button on the display area. To finish the line, 

the right mouse button must be pressed. 

Polygons vertex are added with the left mouse button on the display. To close the 

polygon the right mouse button must be pressed. 

3.3.8 Load HDF 5 Data Items 

HDF 5 Data Items are a special case of data items, because the user has to perform 

several steps before viewing them. MOHID GIS expects HDF 5 file to contain spatial and 

temporal information about the data set which will be loaded. All HDF 5 files produced 

by MOHID numerical programs contain this information. To display the information 

contained in a HDF 5 file the following are required: 

1. Add a HDF 5 file like described in Adding Data Items; 

2. Select the new added data item from the list view and access its properties (like 

described in Data Items Appearance). A dialog window like shown in Figure 3-8 

will appear; 

3. Pressing the “Data Selection” button, located on the right hand side of the 

window, to select data from the HDF 5 file which is to be represented; 
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Figure 3-8: Properties window of a HDF 5 Data Item 

4. A window like shown in Figure 3-9 appears. This window enables the user to 

select how each kind of information is to be represented and what is the spatial 

and temporal information associated with the data sets. Information to be selected 

is divided into required information and optional information. Required 

information is related to temporal, spatial and mapping reference of data sets and 

optional information are the data sets themselves. Information is selected by 

dragging items from the HDF 5 tree view located on the left side of the dialog 

window to the respective list view on the right side of the dialog window (or 

using the Action command from the main menu); 
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Figure 3-9: HDF 5 Data Selection Window 

5. Spatial information about the data sets is required and should either be the data 

sets Connection X/Y or Latitude / Longitude, depending on coordinates used in 

MOHID GIS’s display view. Spatial information is added by selecting the Grid 

list view. After adding spatial information the grid list view should look like the 

one shown in Figure 3-10; 

 

Figure 3-10: HDF 5 Data Selection Window after adding spatial information 

6. Mapping information tells MOHID GIS if a given grid point is to be represented 

or not (e.g. water points vs. land points). Mapping information stored in HDF 5 
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files produced by MOHID numerical programs are: (i) Waterpoints, OpenPoints 

or BasinPoints. Mapping information is added at the Mapping list view. After 

adding mapping information the mapping information list view should be similar 

to the one shown in Figure 3-11; 

 

Figure 3-11: 5 Data Selection Window after adding mapping information 

7. The third required information is the temporal information. Time information is 

added into the time list view in a similar way spatial and mapping  information is 

added; 

8. By selecting Settings -> General… one has access to general settings dialog 

window, which permits to choose several settings (Figure 3-12). Here the user can 

choose which slice is to be imported from a 3D matrix and how the “Quick Add” 

button from the menu bar behaves. This button allows adding with a single click 

all required information (temporal, spatial and mapping). 
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Figure 3-12: Data Selection Window General Settings 

9. Optional information tells MOHID GIS what is actually to be represented. There 

are four ways to represents information: (i) color matrix, (ii) contour lines (iii) 

vector plot, and (iv) lagrangian particles. Information added to (i) and (iii) must 

be kind of 2D or 3D matrixes (e.g. flow modulus, nitrate concentration, surface 

water content). Information added to (iii) must have an X and a Y component 

(e.g. flow velocity, wind velocity). Information added to (iv) is the one produced 

by the lagrangian module. Optional information has its source usually in the 

“Results” folder of the HDF 5 Tree View. Figure 3-13 shows an example of the 

Data Selection Window after adding Vector Plot information;  

 

Figure 3-13: Data Selection Window after adding vector plot information 
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10. By choosing Close Return from Data Selections main window all selected data 

will be loaded and the window will close; 

11. In the Properties window of the HDF 5 Data Item now it’s possible to set settings 

related to the representation of the selected data sets. Only settings for which data 

sets were loaded are enabled. Figure 3-14 shows an example of this. Settings for 

colors are the same as for Grid Data Items, Contour Lines width is given in 

display view units (not in pixel), vector scaling is also referred to display view 

units (a scaling of 1000 means that a vector of 1 m/s will be represented by an 

arrow of 1000 display view units). 

 

Figure 3-14: Properties window of a HDF 5 Data Item after Data Selection 

After loading data from HDF 5 files the user can step through the loaded data sets by 

animating the display view, using the animator (see Using the Animator). 

3.3.9 Zooming & Panning 

Several methods are available (in XY Views) to zoom and pan the current image. From 

MOHID GIS’s mains menu the following options are available: 

• Zoom Rectangle – display will zoom to rectangle area selected with the mouse; 
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• Zoom Checked Items – display will zoom the smallest rectangle which contains 

all checked items in the list view (this option is also accessible through a pop-up 

menu in the list view); 

• Zoom Selected Items – display will zoom the smallest rectangle which contains 

all selected items in the list view (this option is also accessible through a pop-up 

menu in the list view); 

• Zoom Extended – display will zoom the smallest rectangle which contains all 

items in the list view; 

• Zoom Out – display area zooms in by 10%, using the center point as reference; 

• Zoom In – display area zooms out by 10%, using the center point as reference; 

• Pan – pans the image with the mouse;  

“Selecting Action -> None” stops any previously selected action. It’s also possible to 

zoom in / zoom out using the mouse wheel. 

3.3.10 Inquire Information 

To inquire information about a given area, the user has the possibility to select Action -> 

Info -> Info Area / point from MOHID GIS’s main menu. After selecting the desired area 

a window like shown in Figure 3-15 will show information about the data items in the 

selected area.  

 

Figure 3-15: Dialog window showing information found in the selected area 
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3.3.11 Add Legends 

Several types of legends can be added to the display view. These legends are: (i) a legend 

text at the bottom of the display are, (ii) a north indicator, (iii) a horizontal scale, (iv) a 

rainfall indicator and (v) color scales for each data item.  

A legend text at the bottom of the display area can be added by selecting OpenGL -> 

Bottom Legend… from MOHID GIS’s main menu. A dialog window like shown in 

Figure 3-16 appears. The legend text (two lines) as well as the font size and type, can be 

chosen. For the legend text to appear in the display area the “Show” checkbox must be 

checked. There is an option to visualize time. The time shown will depend on the current 

animation time / index (see Using the Animators). 

 

Figure 3-16: Bottom Legend Text Settings 

After closing the bottom legend text dialog window, the legend text will be shown at the 

bottom of the display area (see Figure 3-17). 

 

Figure 3-17: Bottom legend in the display view 

A north indicator can be added to the display area by selecting OpenGL -> North 

Indicator… from MOHID GIS’s main menu. A dialog window like shown in Figure 3-18 

appears. The location (in pixels) of the lower left corner of the North Indicator like the 
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width and height must be supplied by the user. Two types of North Indicators are 

available. 

 

Figure 3-18: North Indicator Settings 

A horizontal scale, which indicates a distance, can be added to the display area by 

selecting OpenGL -> Horizontal Scale… from MOHID GIS’s main menu. A dialog 

window like shown in Figure 3-19 appears. Like for the North Indicator the user has to 

specify the location of the scale. Scale units can be meters or kilometers. 

 

Figure 3-19: Horizontal Scale Settings 

3.3.12 Save Images 

It’s always possible to save the current display view as image in several file formats. By 

choosing Data Items -> Save Image from MOHID GIS’s main menu, a dialog window 

like shown in Figure 3-20 appears. In this window the user can choose the file format and 

destination of the file. 
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Figure 3-20: Save the current display view to a file 

3.3.13 Using the Animators 

Animators allow to animate, the display view, stepping through loaded data sets from 

HDF 5 files and time series. MOHID GIS incorporates two types of animators: (i) an 

index based animator and (ii) a time based animator. Index based animations use the 

indexes of the data sets loaded and time based animations are based on a user defined 

time span and time step. By choosing OpenGL -> Animator -> Index Based Animator 

from MOHID GIS’s main menu, one has access to the first one (choose Time Based 

Animator from the same menu to access the second one). The animator appears below the 

list view in MOHID GIS’s child window, like shown in Figure 3-21. Start and end fields 

indicate the current limits of indexes of all loaded HDF 5 data items, buttons “->” and “<-

“ can be used, respectively, to step one image forward and backward, Render All button 

loop through all indexes and “Save All…” can be used to save all images to a user 

defined folder. The time based animator works in a very similar way. Animators can be 

hidden by choosing OpenGL -> Animator -> Hide from MOHID GIS’s main menu. 
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 Figure 3-21: Index based animator below list view 

3.4 Tools 

There are a set of tools available from MOHID GIS’s main menu (Tool submenu). Tools 

are designed to create input data files for MOHID numerical programs and are described 

next. 

3.4.1 Create Digital Terrain 

By selecting Tools -> Create Digital Terrain from MOHID GIS’s main menu, the user 

has the possibility to create a Grid Data file to be used as bathymetry input for MOHID 

Water or as topography input for MOHID Land (or any other Grid Data file which will be 

needed by the numerical models). A dialog window like shown in Figure 3-22 will 

appear. This window is an interface to launch the numerical program MOHID Digital 

Terrain Creator.  

On the right side of the window one must specify which grid and sets of XYZ data or to 

be used to create the digital terrain. Optionally a set of polygons can be specified, 

defining where “no compute” areas are (e.g. land points for MOHID Water). The grid 

data destination file must be selected under “Digital Terrain File”. There is a set of 

options available which control the way MOHID Digital Terrain Creator will behave. 
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These options can be accessed by the Options; Advanced Options and Overlapping tabs 

(see Figure 3-23). Under the Option tab one can choose the type of interpolation to use. 

After setting all options one have to press the “Run…” button on the left side of the 

window to execute MOHID Digital Terrain Creator. The output of this numerical 

program is redirected the window located at the upper left corner of Figure 3-22. 

After closing the dialog box the newly created grid data file will be automatically loaded 

into MOHID GIS’s current view. 

 

Figure 3-22: Window to create a Digital Terrain 
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Figure 3-23: Options controlling Digital Terrain Creation 

3.4.2 Remove Depression 

To make topography grid data files suitable for MOHID Land they must be “depression 

free”. By selecting Tools -> Remove Depression... from MOHID GIS’s main menu a 

dialog like shown in Figure 3-24 appears. This window is an interface to launch the 

numerical program MOHID Basin Delineator.  

On the left side of the window one has to select the Grid Data Item from which 

depressions are to be removed, the minimum slope to consider and the new Grid Data file 

to be created. 

After setting all options one have to press the “Run…” button on the left side of the 

window to execute MOHID Basin Delineator. The output of this numerical program is 

redirected the window located at the upper left corner of Figure 3-24. 

After closing the dialog box the newly created Grid Data file will be automatically loaded 

into MOHID GIS’s current view. 
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Figure 3-24: Window to Remove Depressions 

3.4.3 Delineate Basins 

MOHID Land can receive a Drainage Network and a delineation of a basin. By selecting 

Tools -> Delineate Basin... from MOHID GIS’s main menu a dialog like shown in Figure 

3-25 appears. This window is another interface to launch the numerical program MOHID 

Basin Delineator.  

From this window one has the possibility to create data items with information about (i) 

delineation of the basin, (ii) drainage network, (iii) drainage direction, (iv) upstream 

drained area and (v) cell slope. The first data item is a polygon, the second is a drainage 

network and the last three are grid data items. The topography used as base data must be 

specified in the list box on the upper right side of the window. One has the option to 

specify the localization of reservoirs. 

Threshold area is a parameter which is used by MOHID Basin Delineator as minimum 

drained area from which channels of drainage network starts to exist. If one wants to 

delineate a basin, the grid cell of the outlet (of the topographic file) must be specified. 

After setting all options, press the “Run…” button on the left side of the window to 

execute MOHID Basin Delineator. The output of this numerical program is redirected the 

window located at the upper left corner of Figure 3-25. 
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After closing the dialog box the newly created data items will be automatically loaded 

into MOHID GIS’s current view. 

 

Figure 3-25: Window to Delineate a Basin 

3.4.4 Auto Cross Sections 

Drainage Network’s cross sections need to be defined in order for MOHID Land (or 

MOHID River Network) to run. This can automatically be done be selecting Tools -> 

Auto Cross Sections... from MOHID GIS’s main menu. A dialog like shown in Figure 

3-26 appears. This window permits to interpolate trapezoidal cross sections in function of 

the drained upstream area. At the top of the window one has to choose which drainage 

network is to be processed and below one has to specify a set of predefined cross sections 

for given drained upstream areas.  
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Figure 3-26: Window to interpolate Cross Sections 

By clicking the Add… or Edit… button MOHID GIS’s incorporated Cross Sections 

Editor (Figure 3-27) will open. Here there’s the possibility of defining the characteristics 

of a cross section. 

After defining a set of cross sections (at least two covering all drained areas) choose the 

option to interpolate cross sections for the whole drainage network using linear or 

logarithmic interpolation.  

 

Figure 3-27: MOHID GIS’s Cross Section Editor 
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3.4.5 Grid Data Operator 

By selecting Tools -> Grid Data Operator from MOHID GIS’s main menu one has access 

to MOHID GIS incorporated Grid Data Operator. This tool permits to perform basic 

operation over exiting Grid Data Items (Figure 3-28). Possible operations are: 

• equaling a Grid Data Item to a constant value; 

• sum, subtract, multiply or divide a Grid Data Item by a constant value; 

• equalize, sum, subtract or multiply Grid Data Item 1 with / by Grid Data Item 2; 

• perform a linear interpolation over Grid Data Item 1 using Grid Data Item 2 as 

“m” value. 

Operations can be constrained and just applied in grid points (of Grid Data Item 1) which 

match constrains specified under “Constrains”. 

On the right side of the window one can select the operation to perform, and on the left, 

which Grid Data Items are used for the operations. The Grid Data Item which will be 

modified (by pressing the “Run…” button) is always the Grid Data Item 1. 

 

Figure 3-28: Grid Data Operator Window 
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3.4.6 Shape File to Grid Data 

By selecting Tools -> Shape to Grid Data… from MOHID GIS’s main menu a dialog 

window like shown in Figure 3-29 appears. Here one has the possibility to convert Shape 

Files containing polygons into Grid Data Items. The source Shape File must be select 

from the list box at the upper left corner of Figure 3-29 and the Grid which will be used 

from the list box at the lower left corner of Figure 3-29. 

On the right side appears a drop down box which contains all numerical columns of the 

data table which belongs to the selected Shape File. In the Lookup Table one has to 

specify the values which are to be assigned to the grid cells, depending on the numerical 

value found in the data table of the Shape File (for example in Figure 3-29 all grid points 

covered by polygons in the Shape File with Soil Texture Class (SLTXCL) 2 will receive 

a value of 2.75). 

The destination Grid Data File must be specified under “Output File…”. By pressing the 

“Run…” button the Grid Data file will be created.  

 

Figure 3-29: Converting Polygon Shape File into Grid Data 

3.4.7 Shape File To XYZ Points 

By selecting Tools -> Shape to Grid Data… from MOHID GIS’s main menu a dialog 

window like shown in Figure 3-30 appears. There is the possibility to convert Shape Files 

containing points into XYZ Points. The data columns used as Z and text must be selected 
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from the drop down boxes on the right and the destination XYZ file must be specified 

under “Output File”. By pressing the “Run…” button the XYZ Points file will be created.  

 

Figure 3-30: Converting Points Shape File into XYZ Point 

3.4.8 Export To Shape File 

By selecting Tools -> Export To Shape File… from MOHID GIS’s main menu a dialog 

window like shown in Figure 3-31 appears. There is the possibility to convert XYZ 

Points, Polygons, Drainage Network and Lines data items into Shape Files. The Shape 

Files will be created in the same folder where the source data items are located. 

 

Figure 3-31: Exporting Data Items to Shape Files 
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3.4.9 Create Boxes 

MOHID numerical programs use polygons in form of “boxes” to perform initialization or 

output operations. These boxes can be created from Polygon and Grid Data data items by 

selecting Tools -> Create Boxes from MOHID GIS’s main menu. A dialog window like 

shown in Figure 3-32 appears. To proceed, one has to choose one Grid Data data item 

and one Polygon data item. Under “Boxes File” the destination of the box file to be 

created is chosen. By clicking OK, the box file will be created and the dialog window 

closes. 

 

Figure 3-32: Creating Boxes for MOHID numerical programs 

3.4.10 Create Grid Time Series Location 

MOHID numerical programs use points to write time series output. By selecting Tools -> 

Create Grid Time Series Locations from MOHID GIS’s main menu, one has the 

possibility to create an input data file which indicates MOHID numerical programs where 

grid based time series are to be written. A dialog window like shown in Figure 3-33 

appears. To create a Time Series Location file, one has to choose one Grid Data and one 

XYZ Points data item from the list boxes. Under “Location file” the destination file is 

specified. DT Output indicates MOHID numerical programs with which time step time 
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series will be written. By clicking OK, the time series location file will be created and the 

dialog window closes. 

 

Figure 3-33: Create Grid Time Series Locations 

3.4.11 Create Node Time Series Location 

By selecting Tools -> Create Node Time Series Locations from MOHID GIS’s main 

menu, one has the possibility to create an input data file which indicates MOHID 

numerical programs where node based time series are to be written. A dialog window like 

shown in Figure 3-34 appears. To create a Time Series Location file, one has to choose 

one Drainage Network and one XYZ Points data item from the list boxes. Under 

“Location file” the destination file is specified. DT Output indicates MOHID numerical 

programs with which time step time series will be written. By clicking OK, the time 

series location file will be created and the dialog window closes. 
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Figure 3-34: Create Node Time Series Locations 
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4 MOHID Postprocessor 

4.1 Introduction 

MOHID Postprocessor is a graphical user interface which displays data stored in HDF 

files as animation on the screen. This tool allows you to visualize the temporal evolution 

and spatial distribution of any property as a continuous animation. The data can be 

displayed in several ways like, color maps, isolines, vector plots and particle (for the 

lagrangian model). The display can be done in different views: XY slice, XZ slice, YZ 

slice, TZ slice or 3D cube. Usually MOHID Postprocessor will be launched directly from 

MOHID GUI, opening directly the file chosen by the user (see Switching to Post 

processing Mode). 

In order to use Mohid Postprocessor the following steps are usually necessary to perform:  

• open one or more HDF files (See Open a HDF file);  

• select the grid over which to represent the data (See Selecting Spatial 

Information); 

• select the data to represent (See Selecting Information to Display);  

• load the data (See Loading the Data)  

• adjust the settings of the data (See Image Settings)  

• display the data (See OpenGL Window)  

• save the images (See Save the Images)  

MOHID Postprocessor is written in FORTRAN and uses OpenGL to display the results.  

4.2 Main Window 

MOHID Postprocessors main window (with one file opened) is shown in Figure 4-1. This 

window is divided into three main areas: (i) HDF Tree View on the left, (ii) Selection 

Buttons in the middle and (iii) Selection Lists on the right. 
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Figure 4-1: MOHID Postprocessor Main Window 

4.2.1 HDF Tree  

The HDF Tree displays, in a hierarchical way, the contents of an HDF 5 file. The 

symbol  represents a HDF file, symbol  a group of HDF items and the symbol  one 

single HDF item (one matrix). 

4.2.2 Selection Buttons  

The selection buttons permit to transfer selected data items in the HDF Tree to the 

Selected Data Lists. For instance, to display the modules of the velocity as color map 

select the HDF item in the HDF Tree and then press the Color button (the first button of 

the selection buttons). The information will pass to the Selected Data Lists. By selecting a 

group of data items, all items in the group will pass to the Selected Data Lists. 

4.2.3 Selected Data Lists  

The Selected Data Lists display the data which is select to be displayed. To remove data 

from any of the lists, select the data items to remove and choose Action -> Delete from 

MOHID Postprocessors main menu. 
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4.3 Selecting Data and Graph Type 

The chapter describes how select data from HDF 5 files produced by MOHID numerical 

models and how the data will be represented using MOHID Post Processor.  

4.3.1 Open a HDF file  

By selecting File -> Open from MOHID Postprocessors main menu a new HDF file is 

added to the HDF Tree.  

4.3.2 Selecting Spatial Information  

Before displaying any data one must specify the grid over which the data is to be 

represented. All HDF files produced by any MOHID numerical program contain a group 

called “Grid”. In this group one can find the information of the grid used during the 

simulation. In order to visualize any information, it’s necessary to specify the following 

spatial information: (i) Horizontal Grid, (ii) Mapping and (iii) Vertical Coordinate. 

Horizontal grid can be either in metric coordinates (HDF items Connection X / Y) or in 

geographic coordinates (HDF items Longitude and Latitude), depending on which 

coordinate system the user wants to represent the information. 

Mapping information informs MOHID Postprocessor which grid points to visualize and 

which to consider “no compute” or “no data” zones (e.g. land areas for MOHID Water). 

Different MOHID numerical programs produce different mapping information (for 

MOHID Water one should add either OpenPoints or WaterPoints and for MOHID Land 

BasinPoints. 

Information about the vertical coordinate must be supplied in the case that one wants to 

represent the data as XZ slice, YZ slice, TZ slice or 3D. The information about the 

vertical coordinate is stored in the VerticalZ group of HDF items. 

4.3.3 Region of Interest 

After selecting Spatial Information one has to set the Region of Interest by selecting 

Settings -> ROI from MOHID Post Processors main menu. A dialog window like shown 
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in Figure 4-2 appears. Here one can choose how to visualize the data and define the limits 

of the matrixes to load.  

 

Figure 4-2: Selecting the Region of Interest 

In the Graph Type Area one can choose in which form to represent the selected data: (i) 

as XY slice, (ii) as XZ slice, (iii) as YZ slice, (iv) as TZ slice or (v) as 3D Cube.  

In the Region of Interest area one can set the limits which are to be displayed and the 

scaling factor by which the grid will be stretched. This factor is particularly important if 

one wants to represent data as XZ, YZ or 3D cube, once in this case it’s usually necessary 

to scale the Z Axis. It’s necessary to take into consideration that the X and Y axis scale 

depend on the Horizontal Grid which was chosen (either metric or geographic 

coordinates) while the vertical axis is always given in meters. This means that for the 

case of metric coordinates one might want to use a large (10-10000?) factor for the Z 

axis, while for geographic coordinates this factor might be very small (0.1 – 0.00001?).  

In the layer area one can choose which slice you want to represent and in the land 

elevation area one can set the depth for the land. 

4.3.4 Selecting Information to Display  

There are different ways to display data: (i) as Color Map, (ii) as  Isolines, (iii) as Vector 

Plot, (iv) as Lagrangian Particle and (v) as Time Legend. 

4-51 



MOHID Graphical User Interfaces 

Every HDF item (expect grid and time information) can be display in any graph type as 

color map. After selecting the desired HDF item(s) from the HDF Tree one can use the 

Color Selection Button to add the item(s) to the Color Data List. 

Every HDF data item (expect grid and time information) can be displayed as isolines. If 

Graph Type is set to TZ graph or 3D Cube isolines can not be displayed. HDF Item(s) are 

added to the Isoline Data List with the Isoline Selection button. 

Vector plots always need an X and a Y component. The components one chooses depend 

on the Graph Type to be displayed. If one wants to display a XY slice the normal X and 

Y components of the property one want to display can be selected (e.g. flow velocity). In 

the case of a XZ slice or an YZ slice one must select the correct components. 

To display lagrangian particles one must select the position of the particles (X, Y and Z) 

and a property which you want to use to “color” the particles. Only the data stored inside 

a Data 1D group of the lagrangian module result files can be used to be displayed as 

lagrangian particles. Data stored in the Data 3D groups can be used as Color Map 

or Isolines. 

By adding HDF Items which are located in the Time Group into the Time Selection List a 

Time Legend will be displayed in the lower left corner of the OpenGL window. 

4.3.5 Loading the Data  

After selecting spatial information, setting the region of interest and selecting the 

information to be displayed, MOHID Postprocessor is ready to load all data. By selecting 

Action -> Run OpenGL… from MOHID Postprocessors main window all selected data 

will be loaded and the Main Window will close. After closing the Main Window the 

OpenGL Window and the Image Tool Window will appear. Depending on the amount of 

data items previously selected for the different categories (Color Map, Isolines, Mapping, 

Time, etc) MOHID Postprocessor determines how many instants are available to display. 

It’s possible to save the selected data items references into a text file (*.dsd), so they can 

be reload again in a posterior usage. By selecting File -> Save DSD from MOHID 

Postprocessors main menu all data items references are saved. By selecting File -> Load 

DSD they are reloaded. 
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4.4 OpenGL Window  

The OpenGL window displays the selected data and it’s divided into several areas. At the 

left you find the legend of the color maps and the isolines values. Legend text is placed at 

the bottom if the figure and in the lower right corner, the date and time of the current 

instant appears. The rest of the window is occupied by the figure itself.  

 

Figure 4-3: OpenGL window 

4.4.1 Manipulating the view  

You can zoom, pan and rotate the figure. In order to do so, perform a click with the right 

mouse button over the figure. A pop-up menu with the available options will be 

displayed. This menu also let you define and restore viewpoints (useful for 3D views). 

4.4.2 Image Tool Window  

After loading the data, besides the OpenGL Window, the Image Tool Window appears 

(see Figure 4-4).  
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Figure 4-4: Image Tool Window 

This window let's you step through the instants step by step by pressing the Render 

button. If you press the Render All button, all instants are displayed. The arrows <- and -> 

let you step backward and forward without rendering the images. If you press the 

Settings… button, Mohid Postprocessor allows you to manipulate the Image Settings. If 

you press the Save to File button, the images can be store in a file. 

4.4.3 Image Settings  

By selecting the “Settings…” button from the Image Tool Window, the Image Settings 

window will appear (see Figure 4-5). Here it’s possible to define a set of settings which 

indicates MOHID Post processor how the final image will be rendered. 

 

Figure 4-5: Image Settings Window 
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The Image Settings Window allows to change the settings related to the image. Most 

common image settings are: (i) Color Settings, (ii) Isoline Settings, (iii) Vector Settings 

and (iv) Particle Settings which are described below. Other settings are: 

• Scale   - to display a metric scale;  

• Wind   - to display a wind indicator; 

• Lights  - to set light options (important for 3D views);  

• Texture - to set texture images;  

• Flight   - to set up an animation which “flies” through the 5 defined 

viewpoints; 

• Slices  - adds XY, XZ and YZ slices to a 3D view;  

• Layers  - defines the order of the item (e.g. vector above isolines);  

• Bottom - Color of the bottom / land points; 

• Add. Legend - Additional Legend to be placed over the figure;  

• Gridlines - Turns Gridlines on/off; 

4.4.3.1 Color Settings Window 

The Color Setting Window (Figure 4-6) let's you specify how to display the Color Map. 

There are two color scales available: gradual color and discrete color. 

If you check the Normalize button all data will be scaled to range between 0 and 1.  

The transparency factor let you choose the transparency of the color (0 completely 

transparent, 1 completely visible). 

4-55 



MOHID Graphical User Interfaces 

 

Figure 4-6: Color Settings Window 

4.4.3.2 Isolines Settings Window 

The Isolines Setting Window (Figure 4-7) let's you specify how to display the Isolines. 

There are two types available: continuous isolines values or discrete isolines values. 

The line width is the width in pixels whit which the isolines are drawn. The color button 

let you choose on which color scale the lines will be based. 

 

Figure 4-7: Isoline Settings Window 
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4.4.3.3 Vector Settings Window 

The Vector Setting Window (Figure 4-8) let you specify how to display the Vectors Plot. 

In the vector settings area you can define how the arrows are displayed.  

The Scale value indicates the size of the vector, taking into account the velocity modulus. 

For the present case, an arrow representing a velocity modulus of 1m/s will be 

represented with an length of 500m (be aware that in the case of geographic coordinates 

it would be represented by 500º, so in this case you must select a very small scale value).  

The X Factor and Y Factor can be used to scale a vector. This is useful if you represent 

XZ or YZ slices with vertical distortion (in this case you should use the same distortion 

values as in the ROI Settings). 

X Step and Y Step indicate how many arrows are to be displayed. A value of 3 just 

displays every third arrow.  

The Cut Above permits to omit the representation of vector with a flow modulus above 

the given value.  

The reference Vector area let's you plot a reference vector on the final figure. A value of 

0 for the size of the reference vector omits its representation. 

 

Figure 4-8: Vector Settings Window 
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4.4.3.4 Particle Settings Window 

The Particle Setting Window (Figure 4-9) allows specifying how to display the 

Lagrangian Particles.  

The Size value indicates the size of the particle. Initially this value is always set to 0 so 

no particles will be displayed. Set the size to an indicated value, depending if you are 

using metric or geographic coordinates. The show ROI checkbox indicates to MOHID 

Postprocessor if only particles which are located inside the current ROI settings are 

represented or all particles.  

The coloring of the particles depends on the color scale you choose. If you use a constant 

color, the transparency can be variable with the data you added as particle color. This is 

useful to visualize plumes. 

 

Figure 4-9: Particle Settings Window 

4-58 



MOHID Graphical User Interfaces 

4.4.3.5 Save / Load Image Settings 

You can save the image settings into a binary file (*.ims ), so you can load in a posterior 

usage the same settings. Besides all image settings, also the current viewpoint is saved. 

Please note that this option just work if you want to represent an image with the same 

items (e.g. Color map and Isolines ON, all other items OFF). 

4.4.4 Save the Images  

It’s possible to save all images by selecting Save to File from the Image Tool Window. In 

the dialog window which pop-ups it’s necessary to specify the Name of the Images and 

the directory where they will be stored. Optionally it’s possible to create automatically an 

animation of the files and/or store them in a ZIP file. To do so it’s necessary to specify in 

the Utilities textbox the folder where the utilities (zip.exe and bmp2avi.exe) are located 

(the folder where the MOHID package was installed). 

Please note that during the entire saving process the OpenGL window should 

remain as the topmost window of your desktop. 
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5 MOHID Time Series Editor 

5.1 Introduction 

MOHID Time Series Editor is a graphical user interface which allows the user to 

visualize in a quick way time series data required or produced by the MOHID numerical 

programs. Usually MOHID Time Series Editor will be launched directly from MOHID 

GUI, opening directly the file chosen by the user (see Switching to Post processing 

Mode). 

MOHID Time Series Editor is written in VB.NET and uses Office Web Components to 

display the results. Figure 5-1 shows the main window of MOHID Time Series Editor’s. 

 

Figure 5-1: Empty MOHID Time Series Editor Main Window 

5.2 Open a File 

By selecting File -> Open from MOHID Time Series Editor’s main menu a new time 

series is added to the list view on the left side of MOHID Time Series Editor’s main 

window.  

5.3 Selecting Series to Display 

After opening a new file a dialog window like shown Figure 5-2 appears. Here the user 

has the option to select which time series are to be displayed. 
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Figure 5-2: Dialog to choose the series to display 

The process of opening files and selecting series must be repeated for all time series to 

display. After selecting a set of series, MOHID Time Series Editor’s main window 

should look like the one shown in Figure 5-3. 

 

Figure 5-3: MOHID Time Series Editor Main Window with series 

5.4 Display the Data 

By pressing the “Draw Chart” button at the lower right corner in MOHID Time Series 

Editor’s main window, the Chart Window which displays the selected time series will 

appear (Figure 5-4). 
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Figure 5-4: Chart Window 

By selecting commands from the toolbar at the top of the Chart Window, the chart can be 

manipulated in a similar way as in MS Excel. By selecting the “Save Image” button the 

current image is saved. 

5.5 Save entire graphic 

The user is allowed to save an entire graphic (values and settings) by writing it to XML 

format. To do this press the SaveXML and select the file name. The entire graphic can be 

loaded later by selecting “File -> Open XML Time Serie”. 
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